1. Howdy partner! You seem new here. Why don't you make an account and join the discussion? You can register here.
    Already have one? Then you login here!
Login button here

Lost Son- Missing Quest Giver

Discussion in 'World 3 (Enewetak)' started by Sixtus Cardinal, Aug 27, 2012.

Share This Page

  1. I went all the way to Mrs. Anderson and accepted the quest for the lost son. She told me to go to the forest meadow to look for Dean. I found the forest meadow and am there now, but Dean is missing. I tried logging out and deleting cookies. Not sure what to do next. I have completed all the quests to get to this point.
     
  2. idiomatiks

    idiomatiks Guest

    try looking in county 3.
     
  3. You are right, thanks for the help. I looked in every county before, I guess it just takes a while for it to show up. I wonder why it is not by the Forest Meadow like it says in the quest?? Is this a bug, since in my other world it was where it said?
     
  4. idiomatiks

    idiomatiks Guest

    i agree.
    and this location is not even between forest meadow and his mother.

    (i had no problems, cause i did not read the text and only looked for white dots over the map)
     
  5. I tried looking for the white dots and this one wasn't there when I posted. This isn't the first time it took a few hours for the next quest giver to appear for me despite refreshing and deleting cookies.
     
  6. Now I am having the same problem with the bounty hunter. I defeated him in the duel but cannot find him on the map to continue the quest line. I assume he would be right next to Dean, but there is nothing there. I will wait a few hours and see what happens.
     
  7. Did you find the bounty hunter? He still hasn't shown up for me.
     
  8. Zeta

    Zeta Guest

    ghost town look there
     
  9. Yeah, he finally showed up in the ghost town a few hours later. I"m still not sure why it is taking a few hours for each new quest giver to appear. Now I'm stuck on the one needing the roll of wire. I have done the Setting up telegraph poles job at last 25 times and still have not gotten even 1 product! :(